sabato 22 gennaio 2011

Anjuta compile error You must have `glib' installed

Hi all
today I tried Anjuta IDE, very nice enviroment, 
unfortunately when I tried to compile a simple hello world source file I got this error:

**Error**: You must have `glib' installed.

but fortunately after some googoling I found the solution, and it's quite simple to do, just this:

sudo aptitude install libglib2.0-dev libgtk2.0-dev

after that I compiled the source without issue :)

if you then are working with SDL libraries and want to compile try this:

sudo apt-get install libsdl1.2-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-net1.2-dev libsdl-ttf2.0-dev

to use SDL libraries for sound install this:

sudo apt-get install libsdl-mixer1.2-dev libsdl-sound1.2-dev

a sound alternative could be OpenAL ( )

sudo apt-get install libopenal-dev


Nessun commento:

Posta un commento